Monday, June 11, 2007

--versionのバージョン情報が信じられなくなった日

あるPPP通信カードで設定ファイルを生成するコマンドwvdialconfが失敗するという情報が挙がりました。wvdialはppp接続をするためのツールです。

前に組み込んでいたwvdialconfと現状の組み込んであるwvdialconfではバージョンが同等であるにもかかわらず、現状のものでは失敗する。ライブラリ関係のバージョンの違いとの推測も考えられたがそれもなし。実際に前に組み込んでいたwvdialconfとそれに依存するライブラリを現状のものに移行したら動作しました。

--versionは信じられないですね。バイナリレベルで差分があると困ります。